Page 1 of 1

Can Bus connections/settings

Posted: Fri Nov 10, 2023 12:08 pm
by DaveDLE
Hi
My name is Dave and I am very much hoping someone can help me.
I am now on my forth Android radio trying to replace my existing unit in a Hyundai ix35 2014, CRDI Premium car.
The first unit came with the wrong lead that didn't fit my existing radio sockets, so returned it, after much research reordered but everyone came with the correct sockets but could see the connection didn't match so returned them, all from Amazon so easy to do, tried emailing the supplier but nobody replied so turned to Ebay. Corresponded with a guy who after sending various phots said he would supply the correct lead, it came but didn't work, the plug unit was labeled 'Sorento', he then sent a replacement lead which had some success in that the right hand side speakers work only, no R/H/S no woofer no steering wheel functions, when I go into reverse the radio show guide lines but no display, it is set to 'NSTC'
I suspect it has something to do with the CanBus box, I have selected various settings in the 'Factory Settings' page but to no effect.
Please can someone help me, I have spent hours trying to get it working, every cable sent comes with the speakers wires which are not needed there are no speaker wires at the radio as it has an amplifier in the boot.

Re: Can Bus connections/settings

Posted: Fri Nov 10, 2023 1:53 pm
by Pie-Man
Hi

That's quite a journey you have been on.


Do you have a factory installed rear camera?

Did it work before the android was installed?

The lines for the camera are often generated by the headunit so you may have not connection to the camera at all.

You could try a standard camera if the headunit has the right connection.

You still don't have the right cables if you have leads that don't fit anything (speakers) which could be the camera problem?